It is currently Sun Jul 15, 2018 3:18 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 12:00 am 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
So, i started hearing this clunking sound coming from my engine when i am in park or just sitting at a light or something. Idk what it is, under the hood looks good. Oil was too low, so i filled it, but the sounds not gone.

IDK Help?

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 9:23 am 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
Oh my lol, start looking for a new engine/ jeep now. That happened to mine last week and this week I am driving a toyota . She locked up on me on the highway. Hope it turns out better than mine. How many Miles on her?

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 12:29 pm 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
:.(..

175000 miles, just dropped $2k on a brand new Trans...

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 4:38 pm 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
yeap, that sounds about right :dead: . Sorry to hear that man, that is like the 4th KJ thats gone down on the site in the last 2 weeks.

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 8:23 pm 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
hmm. great...

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Wed Oct 13, 2010 10:54 pm 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
EAGLE01_2002Libby wrote:
hmm. great...

lets just hope im completely wrong, word of advice though, get it to the shop ASAP. I drove on mine for a week thinking I would be okay a little while longer. Saturday night on I87 im in the Left hand lane, and she gives out, had to make my way all the way over to the breakdown lane and sit on the highway for 45mins.

Now im stuck with my fathers toyota avalon :roll:

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Thu Oct 14, 2010 12:25 am 
Offline
Moderator / Lifetime Member
Moderator / Lifetime Member

Joined: Thu Jul 07, 2005 5:49 pm
Posts: 27708
Location: Central Ohio/ Tanzania
Check your cats as well they can make a sound like the whole bottom end is going out sometimes
But then you said you ran it low on oil, don't people check their oil on a regular basis anymore?
I know of a bunch who have as many miles and no problems so don't assume until you get it checked out

_________________
MUDD'S MOTORSPORT'S We do IFS lift installs ,
03 OVERLAND EDITION /Kilby-Skidrow-Mopar-4XGuard skids/ 2.5 inch TOTAL CONTROL JBA coilovers -JBA Arms/MOABS-31 Goodyears/ 4.10's etc, 04 Kilimanjaro Edition loaded


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Thu Oct 14, 2010 11:51 pm 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
Actually i check my oil once a week. I just refilled it. A week later i burned it all.

It only does this in Park and Neutral

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Fri Oct 15, 2010 12:35 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Sun Feb 01, 2009 2:29 am
Posts: 6014
Location: Hillsborough, NC / Petersburg VA
a week later and you burned it all? are we talking.. part of a quart or are we talking about basically ALL of it

if you're leaking OR burning that much oil there is a serious problem somewhere that indeed needs immediate attention

I know over the period of about 10,000 miles mine either burns, or seeps about 1/4 to 1/3rd of a quart fairly consistently, most of it goes out of the timing chain cover :oops:

as for the knock, could be a motor mount, they'll often knock in park / neutral when one of them is broken but usually it's a single clunk and nothing repetitive

if the knock went away with the re-addition of oil, you mechanically may be just fine, however the cause of the exit of oil needs to be identified and resolved

_________________
03 Renegade (Black)
177k miles 3.7L gas - 45RFE
Command Trac / 4.10s
Lift: ft. 790+ rr. JBA4+
The last of the TrailReady Front&Rear Bumpers and TR Rock Rails
Jarhead Offroad light covers
31x10.5R15 RedLetter Grabbers on Blackrock Dunes
L.O.S.T #KD098632


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Fri Oct 15, 2010 8:54 am 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
I went through 1.5 quarts in about two weeks.
The knocking is getting worse.
I am currently not driving it because it sounds so bad.
Ill be taking it in next week. Although, my mechanic is an hour away. lol
So, hope for the best

Thanks everyone

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Fri Oct 15, 2010 6:57 pm 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
keep me updated I am interested to see what hapens

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Fri Oct 15, 2010 7:55 pm 
Offline
LOST Addict
User avatar

Joined: Sun Jan 06, 2008 4:43 pm
Posts: 1248
Location: Las Vegas, Nevada
EAGLE01_2002Libby wrote:
I went through 1.5 quarts in about two weeks.

I don't think that is all that uncommon. I add about 1-2 quarts of oil in-between oil changes. I have no knocking but I do burn it off somewhere as there is no oil leaking anywhere that I can see. *shrug* I have talked to a lot of the local Jeep owners and out of the 40 or so that i talked to, about 30-35 add that much oil. Perhaps it is the heat we have here though? I know dumb response but :D

_________________
My Rig:
2008 Jeep Wrangler JKU
OME HD lift
35" tires (thus far)
plus a ton of other things. J.E.E.P.


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Sun Oct 17, 2010 4:17 pm 
Offline
LOST Addict
User avatar

Joined: Tue Jul 14, 2009 12:20 pm
Posts: 2294
Location: Orange Park, FL
Does it sound like this??

Image

If it does, your engine is toast.....
Prepare to drop a big chunk of change on a new one. :dead:


That was my engine in january. Ran a little low on oil, spun a couple bearings, threw a rod through the block, it was nasty.

_________________
'02 Jeep KJ 4x4- Gone
'92 YJ- lift, swampers, bumpers....yeah, its pretty sweet.
*DISCLAIMER*: I can not be held liable for anything I say on the forums or in real life.
I also can not be held liable for any jeep breakage or life problems caused due to my advice being taken.
:D


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Sun Oct 17, 2010 9:26 pm 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
Budke wrote:
Does it sound like this??

Image

If it does, your engine is toast.....
Prepare to drop a big chunk of change on a new one. :dead:


That was my engine in january. Ran a little low on oil, spun a couple bearings, threw a rod through the block, it was nasty.


DAMNNNNN that was loud haha, alot worse sounding than mine. How much were you quoted for a new engine? Or did you just decide to buy the wrangler.

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Mon Oct 18, 2010 3:18 am 
Offline
LOST Addict
User avatar

Joined: Tue Jul 14, 2009 12:20 pm
Posts: 2294
Location: Orange Park, FL
Vranes17 wrote:
DAMNNNNN that was loud haha, alot worse sounding than mine. How much were you quoted for a new engine? Or did you just decide to buy the wrangler.


4500 total for a remanned long block and all the labor and other odds and ends.
Oh, and a new radiator.

Then after about 6-7 months I got bored with it, started my hunt for my long lost lust of owning a wrangler.
Sold the jeep about a month and a half- 2 months ago and bought my current YJ at the end of september.
Haven't looked back since! Every time I see a black KJ I always look to see if its mine. Have yet to see it since I sold it. :cry:

_________________
'02 Jeep KJ 4x4- Gone
'92 YJ- lift, swampers, bumpers....yeah, its pretty sweet.
*DISCLAIMER*: I can not be held liable for anything I say on the forums or in real life.
I also can not be held liable for any jeep breakage or life problems caused due to my advice being taken.
:D


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Mon Oct 18, 2010 3:52 pm 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
Hey Budke, Great video.

Do you remember if your Libby only made that sound in Park and Neutral?
Thats what mine does.

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Mon Oct 18, 2010 4:34 pm 
Offline
LOST Addict
User avatar

Joined: Tue Jul 14, 2009 12:20 pm
Posts: 2294
Location: Orange Park, FL
EAGLE01_2002Libby wrote:
Hey Budke, Great video.

Do you remember if your Libby only made that sound in Park and Neutral?
Thats what mine does.


Mine did it ALL the time.
Park, neutral, drive, reverse, everything.

Do you happen to have a transmission skid on your kj??

_________________
'02 Jeep KJ 4x4- Gone
'92 YJ- lift, swampers, bumpers....yeah, its pretty sweet.
*DISCLAIMER*: I can not be held liable for anything I say on the forums or in real life.
I also can not be held liable for any jeep breakage or life problems caused due to my advice being taken.
:D


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Mon Oct 18, 2010 6:03 pm 
Offline
LOST Junkie
User avatar

Joined: Fri Nov 06, 2009 10:56 pm
Posts: 760
Location: Westchester,NY
Budke wrote:
EAGLE01_2002Libby wrote:
Hey Budke, Great video.

Do you remember if your Libby only made that sound in Park and Neutral?
Thats what mine does.


Mine did it ALL the time.
Park, neutral, drive, reverse, everything.

Do you happen to have a transmission skid on your kj??


I do and when I checked it, there was an oily substance on it :grim:

_________________
'02 Liberty Limited 4x4
-Selec Trac
-MTR's 245/75-16
-Rock Lizard Super Skink Sliders(custom)
-Engine skid, Skidrow Transmission skid
-4" Lift - JBA 4.5 Gen A-arms
Installed@165,920k
Pilot lights on cowl
Engine replacement at 175k


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Tue Oct 19, 2010 12:41 am 
Offline
LOST Addict
User avatar

Joined: Tue Jul 14, 2009 12:20 pm
Posts: 2294
Location: Orange Park, FL
Well when I had a tranny skid on my '02 it would make noises while in reverse and when going around some turns and a few random times.
Ended up it was the exhaust hitting the skid,

_________________
'02 Jeep KJ 4x4- Gone
'92 YJ- lift, swampers, bumpers....yeah, its pretty sweet.
*DISCLAIMER*: I can not be held liable for anything I say on the forums or in real life.
I also can not be held liable for any jeep breakage or life problems caused due to my advice being taken.
:D


Top
 Profile  
 
 Post subject: Re: ENGINE PROBLEMS!
PostPosted: Fri Oct 22, 2010 2:23 am 
Offline
LOST Member
User avatar

Joined: Fri Oct 30, 2009 5:01 pm
Posts: 174
Location: Metro Detroit, Michigan
HEY THANKS EVERYONE.

I took it to the shop yesterday. They fixed everything for $85

The noise was loose torque converter bolts (just had my trans rebuilt a month ago)
Oil Change
Found out what the high pitched noise was when i turned and fixed it!

SO, no new engine or jeep
I get my baby back tmrw!!! :JEEPIN:

_________________
Silver 2002 Liberty Sport
Couple of Mods
Many future Mods to come...

..==oooo
/_|_\===\
[==[ ]--|ollllllo|
()_).....()_)-o-)_)..
LIBBY!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com