It is currently Wed Jul 08, 2020 9:55 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Long time no see - quick tech radio question
PostPosted: Wed Jun 17, 2020 3:11 pm 
Offline
LOST Newbie

Joined: Thu Dec 29, 2016 4:30 pm
Posts: 24
Hello all!
***2012 KK sport, 2 inch OME lift***

Its been a dang near three years... I took some upgrading time off as I needed to focus on school payments, but something has come up that requires my KK attention...

Around January, my radio would start cutting off and not allow me to adjust volume. No noise or music. Nothing. And then, I would turn the car on one morning and music would come back only to cut out the next time I turned the car on. More recently, there started to be longer gaps in between the time I'd be able to actually listen to music, and this past week, it started playing again but music cuts in and out every 3 seconds. My friends seem to think its a connection issue with the 2012 stock KK head unit, so I decided I'd purchase a new stereo/radio.

The one I purchased: https://www.bestbuy.com/site/sony-6-2-a ... Id=6283607

I am sure there are better ones out there, but I made sure it would fit my Jeep and got the install kit, etc- I really need my music back lol especially since its summer time.

My questions:

1) Does anyone have a link to an install guide either for this model, or just a general how-to? I've done lifts and some other minor cosmetic stuff but have always stayed away from electrical work for fear of screwing something up.
2) I have a 5500 watt BAMF power akoustics amp with two SUBS in my trunk. I'd rather not have to take it to the guy who installed it as he charges a lot for installs. Do you think I am going to have issues with hooking the amp to the head unit, or am I just worrying? I rarely ever bump the amp to its full capacity. I bought it off my cousins and usually keep it around 5-10%
3) What tools are necessary for a head unit swap like this and how much time should I block off?

If anyone has done such an install and has an amp/subs in their KK as well, please let me know, I'd love to hear how you got it done and if you ran into any issues.

I hope you all are in the best of health, and than you for reading my post! I appreciate any and all feeedback.

Best,


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com