It is currently Wed Aug 15, 2018 11:04 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: ECU replacement delayed from dealer? Can't get parts??
PostPosted: Tue Feb 27, 2007 7:32 am 
Offline
Lifetime Member
Lifetime Member

Joined: Fri Oct 06, 2006 9:15 pm
Posts: 63
In January I took my 05 sport diesel in for the Transmission and TC flash. Dealer burned the ECU unit I think? Said I needed a new one?? I have been waiting for a replacement part. In the meantime the milage has gone south and the battery will be dead after two days. Check engine light stays on. Get lots of black smoke out the tail pipe. The dealer said it was OK to drive the Jeep. Anyone have any problems like this? Any suggestions would be appreciated.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 28, 2007 12:41 pm 
Offline
LOST Newbie

Joined: Thu Sep 28, 2006 12:06 pm
Posts: 71
Location: Bergen, NJ
i had a similar problem, but mine is a 2005 gasser with 20000 miles on it, dtc codes for too much fuel enrichment on both bank 1 and 2 never solved, 7mpg, black smoke on full throttle, 3 months at the dealer, several o2 sensors, throttle body and sensors, a few catalytic converters, a few wire harnesses, 2 ECUs, (several reflashes) 2 cylinder heads, yes, you read that right, cylinder heads. and it is still at the dealer 6 months later. Magnusond Moss Warrenty Act + a lawyer = 2006 liberty with same mileage.
Good luck and i mean that sincerely.


Top
 Profile  
 
 Post subject: Re: ECU replacement delayed from dealer? Can't get parts??
PostPosted: Sat Mar 03, 2007 9:04 am 
Offline
LOST Addict

Joined: Sat Mar 25, 2006 8:31 pm
Posts: 1465
Location: Kent, OH
StarDreamer.us wrote:
In January I took my 05 sport diesel in for the Transmission and TC flash. Dealer burned the ECU unit I think? Said I needed a new one?? I have been waiting for a replacement part. In the meantime the milage has gone south and the battery will be dead after two days. Check engine light stays on. Get lots of black smoke out the tail pipe. The dealer said it was OK to drive the Jeep. Anyone have any problems like this? Any suggestions would be appreciated.

This has been a problem on '05 CRD's. when they get the new TCM it most likely won't take the new flash. They used another customer's '06 CRD as a host to clone the TCM for mine.

Keep an eye on your oil consumption as the excess black smoke is likely caused by sucking oil through the air intake. This causes a chain of events that plus-up the works. You may want to look at the MAP sensor in the intake manifold for excess carbon build-up. I would also assume you have a CEL with the excess black smoke, possibly for EGR function?

_________________
2005 Liberty Sport CRD, Lt Khaki, sunroof

Thankful to now be an EX-CRD owner.


Top
 Profile  
 
 Post subject: Update
PostPosted: Sun Mar 04, 2007 11:51 am 
Offline
Lifetime Member
Lifetime Member

Joined: Fri Oct 06, 2006 9:15 pm
Posts: 63
Just got the Jeep back from the dealer. They used a new method to re flash the ECU. Got rid of the error codes and the dash does not have the check engine light on. Great! They also replaced the EGR valve for the third time?? What is going on here? The black smoke has cleared and the engine seems to run smoother. Thanks for all of the suggestions.


Top
 Profile  
 
 Post subject: After the flash??
PostPosted: Fri Apr 13, 2007 3:31 pm 
Offline
Lifetime Member
Lifetime Member

Joined: Fri Oct 06, 2006 9:15 pm
Posts: 63
Whatever they did was not good. My MPG is now in the pits! Anyone having the same problem? Thanks.


Top
 Profile  
 
 Post subject: Up date on repairs on 05 CRD
PostPosted: Thu Jul 19, 2007 7:08 pm 
Offline
Lifetime Member
Lifetime Member

Joined: Fri Oct 06, 2006 9:15 pm
Posts: 63
Finally got the dead battery problem solved. The selling dealer installed the hitch wiring wrong. It was suppost to be a factory tow package. It was a journey to get it solved three dealerships and I don't know how many techs. The installing dealer didn't have the right wring harness so they made their own. Then connected it wrong. Thus the draw on the battery. I am so glad that mess is over with.


Top
 Profile  
 
 Post subject: Re: Up date on repairs on 05 CRD
PostPosted: Thu Jul 19, 2007 7:19 pm 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Sat Apr 15, 2006 12:56 pm
Posts: 1831
Location: Spokane, WA
StarDreamer.us wrote:
Finally got the dead battery problem solved. The selling dealer installed the hitch wiring wrong. It was suppost to be a factory tow package. It was a journey to get it solved three dealerships and I don't know how many techs. The installing dealer didn't have the right wring harness so they made their own. Then connected it wrong. Thus the draw on the battery. I am so glad that mess is over with.


Gosh never saw this topic before. If I had I would also have alerted you to a TSB for a re-program of the BCM (body control module) to correct a problem that was draining the battery.

What happened on your mileage? The ORM will eliminate the EGR issues.

_________________
Dave

'06 CRD Limited, Lt. Khaki, MOPAR Slush Mats/Skids, DrawTite Front Hitch, Mag Lite, Yakima Bars, Thule Bike Rack, Fumoto, ORM, 245/70 Revo 2

Wish list: Lift, Boulder Bars, Something Bigger in the Front and Back, More Lights


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com