It is currently Thu Dec 14, 2017 8:36 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: No cab heat or defrost
PostPosted: Tue May 30, 2017 8:15 am 
Offline
LOST Newbie

Joined: Thu May 25, 2017 9:02 pm
Posts: 3
I have a 2005 Liberty Diesel. Over the last year and half I have replaced the following, heater core, thermostat, turbo, water pump, and added a switch for the auxiliary vicous (sp) heater (mechanic said the pcm was not telling it to turn on). Mechanic checked all control doors on the heater and I am still not getting heat in cab. AC is working great. I just got this back from the mechanic could there be an air pocket in water lines? The heater lines are hot after vehicle runs for awhile. I am stumped. Thanks for any help

Kelly


Top
 Profile  
 
 Post subject: Re: No cab heat or defrost
PostPosted: Tue May 30, 2017 9:16 am 
Offline
LOST Addict

Joined: Fri Jun 22, 2007 11:43 am
Posts: 3916
Location: Green Cove Springs FL
You should post this in the "Liberty CRD Love that Torque" section

_________________
Bought my '05 CRD on June 2nd '07, used with 29,000 miles.
intake elbow and EGR delete. 7 volt Etecno glow plugs
Yeti stage 2 ECU tune. Straight pipe exhaust. DIY intercooler hoses
Provent and modified factory 180F thermostat
Replaced cylinder head (cracked) at 160,000 miles + ARP studs
Cheap 1 inch lift, 245-75R-16 tires.
Still love it.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com