It is currently Wed Jul 17, 2024 5:44 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Multiple function fail
PostPosted: Tue Feb 28, 2023 12:52 pm 
Offline
LOST Newbie

Joined: Tue Feb 28, 2023 12:09 pm
Posts: 2
I recently, and all at once, had my oil pressure light and water-in-fuel light come and and stay on. The fuel gauge also began waving back and forth at the same time. It never gives a measure of the fuel. This seems to have happened when the vehicle was being jumped by another vehicle.

I also have a different issue of the odometer/trip meter not counting miles. I have checked the wires going to the front wheel bearings and the rear diff. I also pulled up all the carpet the look at the wiring for the fuel sender unit and rear speed sensor, but found no chafing or breaks. I replaced both front hub assemblies and the diff speed sensor. The speedometer does work.

I am new here, any help would be appreciated.


Top
 Profile  
 
 Post subject: Re: Multiple function fail
PostPosted: Tue Feb 28, 2023 1:30 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 7218
Location: Central GA
First thing to check with any electrical problem on these vehicles is the grounds! see picture
If it is an 06 model, check where the wiring harness goes behind the fuel filter head, there is a known problem of wiring chaffing in that area on these models. :banghead:

You should also check the plug in connection on the rear of instrument cluster.
Next, check all fuses with a testlight or ohm meter and make sure you have none that are blown or bad. (you can't just look at a fuse and tell for sure if it is bad or not)

Picture
Image

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Week's BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 Bld.fan/HDClutch
IronrockArms/wwdieselMount

98 Dodge Cummins 24 Valve


Top
 Profile  
 
 Post subject: Re: Multiple function fail
PostPosted: Tue Feb 28, 2023 3:21 pm 
Offline
LOST Newbie

Joined: Tue Feb 28, 2023 12:09 pm
Posts: 2
Thanks for the specifics of the grounding locations. I did previously check the fuses with a multimeter. I also check the plug in the back of the instrument cluster.

It is a 2005 liberty crd


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com