It is currently Sat Nov 28, 2020 4:02 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Cranks, does not start, fire, and has no codes
PostPosted: Sat Nov 21, 2020 1:44 pm 
Offline
LOST Newbie

Joined: Tue Oct 15, 2019 11:12 am
Posts: 3
New to the site, and it's already been a wealth of information. So thank you for that. I have 2 '06 CRD's and hope to keep them forever.

I've read the Noob guide and a host of other threads, when I've had some issues, and have always found the right information.

This particular jeep I just did the Weeks stage 1+2, Hot Diesel Thermostat, "upgraded" the glow plugs to the 5V Bosch metal ones, number one was burnt to a crisp. Also replaced Vacuum lines with silicone lines. Samco Hose upgrade, and the turbo Hose intake upgraded to Silicone. Has 230,000 on it, and just replaced timing belt about 30 grand ago. Other than that, everything else is stock. What a difference removing all that EGR stuff, takes off like a Jet now.

Little history, I've had it for just over 2 years, and twice it's gone into Limp Mode, and I've never really figured out why. There really wasn't anything I really did. However after the first time, it was Timing belt time, so I did all that, and it was fine. Did the limp mode thing again and after a week of sitting just started up and was fine. Thought it was a vacuum issue, so replaced the lines and ran fine, but it really didn't seem like any of the old lines were bad. It also takes a few extra seconds of cranking to start, nothing crazy, but it is a bit elderly on the miles.

Only codes it's thrown are the Glow Plug code. I use torque lite, so not sure if it's reading everything that's there. Now, of course it's throwing all the EGR codes. Since GDE doesn't do the tunes in the US anymore, I'll have to use one on here, again, glad that info is here.

So, now the real reason for the questions... it ran great, drove it for about a week, parked it at night, the next morning, it cranks just fine, and won't start. Changed the Fuel Filter, as I'm in Northern Ohio and it was a bit chilly overnight but nothing crazy, verified I'm getting fuel at the rail, even took off the hose to the pump to put diesel in there and won't even cough like it wants to start. Block heater is plugged in and charged the battery to make sure it's cranking full. I've read the Crank no start no code threads, but nothing ends up being what it appears mine is doing. I don't want to just throw parts at it, but it doesn't seem like there's very many things that can make this not want to run.

I am thinking Crankshaft or Camshaft sensor, but wouldn't they throw a code? Does Torque lite maybe not read those codes? I currently don't have a way to get any real fuel pressure readings, but cracking number one injector appears fuel is pumping just fine.
If I do just throw a crankshaft sensor on it and it works, I'll still scratch my head because I hate not knowing why it's not working or throwing a code... or maybe I just need a really good Code reader. :D

Any ideas would be greatly appreciated, even if the consensus is to just throw a crankshaft sensor on it to see.


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Sat Nov 21, 2020 2:11 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 5795
Location: Central GA
CPS are notorious for going bad and not setting a DTC. :banghead:
If you are getting fuel and the CP3 is pumping the rail up to proper pressure, then something is not firing the injectors off.
The ECM has to see certain things before it will fire the injectors to start the engine.
No security issues with key fob. Red warning on dash cluster off.
CPS and cam sensor would be good places to start.
Have you had it scanned, not all DTC's turn on the check engine light.
A good scan tool would tell you RPM's when cranking engine over.
If the engine is turning over at a good speed and battery voltage is not dropping to low, you got to start a process of elimination.
Deep scanning may save you a lot of time.... :juggle:

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox
GM11 bld. fan/NAPA HDclutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Sat Nov 21, 2020 4:24 pm 
Offline
LOST Newbie

Joined: Tue Oct 15, 2019 11:12 am
Posts: 3
Oh yeah, the Red Dot goes out with Key on. No exhaust when cranking either, like not even the slightest.

I guess if I want to keep these forever, time to invest in a little more than Torque lite. :)

The local garage has the good scanner, but they didn't even know Jeep made a "Liberty Diesel?" When a mechanic opens the hood and says "I've never seen one of these before" probably not going to get much help.

Thanks, time to play pick a part and see what happens...lol.


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Sun Nov 22, 2020 12:54 pm 
Offline
LOST Newbie

Joined: Thu May 26, 2016 4:54 pm
Posts: 25
I have a similar issue, no start, no codes, fuel at the injectors but no smoke or fuel in the exhaust.

Did you solve the problem? What was it?


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Sun Nov 22, 2020 1:39 pm 
Offline
LOST Addict
User avatar

Joined: Thu Sep 06, 2007 9:51 pm
Posts: 6246
Location: Somewhere between Heaven and Hell... But it is really hot here on Earth...
If you are looking for a tech who is experienced with this engine, you won't find one at your local shop. I'm the traveling CRD tech, this is the ONLY vehicle I work on. It DOES seem like you have an electronic issue but there needs to be more investigation.

Email jeep [at] maincomputer [dot com] and we can go from there, the forum software's messaging has been acting up lately and messages aren't always sent properly.
--Jim

_________________
Proud supporting vendor of LOST Jeeps
Provider of high quality CRD service in your driveway.
Need help? Just ask! I've taken it apart more than most.
Email (button below) is preferred to PM
Over 70 CRDs currently driving with my timing belt, rockers, or ARP Studs.
Just remember: Bad noises = REALLY bad things.


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Mon Nov 23, 2020 12:21 am 
Offline
LOST Member

Joined: Sun Apr 06, 2014 5:23 pm
Posts: 361
geordi wrote:
If you are looking for a tech who is experienced with this engine, you won't find one at your local shop. I'm the traveling CRD tech, this is the ONLY vehicle I work on. It DOES seem like you have an electronic issue but there needs to be more investigation.

Email jeep [at] maincomputer [dot com] and we can go from there, the forum software's messaging has been acting up lately and messages aren't always sent properly.
--Jim


There's a ton of techs out there that can do diagnostic on this vehicle. It's a Bosch common rail diesel like many others !

We're not talking about the space shuttle here :frankie:


Top
 Profile  
 
 Post subject: Re: Cranks, does not start, fire, and has no codes
PostPosted: Mon Nov 23, 2020 11:44 am 
Offline
LOST Newbie

Joined: Tue Oct 15, 2019 11:12 am
Posts: 3
Like I mentioned, I have 2 of these, one of which is currently running just fine. Would it make sense to "test" a sensor from the one running to the one not running as a troubleshooting method? I wouldn't want to ruin a sensor testing on the one not running, if that is even a possibility.

And of course, I don't know why, but it's easier to try to mull it over in the brain for a week, only to find out it'll be a cps or something simple...LOL.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com