It is currently Wed Apr 23, 2014 6:59 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 17 posts ] 
Author Message
 Post subject: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 2:26 pm 
Offline
LOST Newbie

Joined: Tue Apr 03, 2012 11:37 pm
Posts: 63
06 CRD - Went to market this morning. Everything was fine. Came out after 20 minutes, engine started a little rough, started driving and noticed lack of power even when floored.
Parked, put car in neutral and revved the engine but RPMs would not go past 2000. Almost acted like it wasn't getting fuel or air? Called tow truck but after about 10 minutes started up again and ran fine. Was able to drive home and engine acted normal. Can't duplicate again but there have been a couple of blips where the engine seemed to lose power over the past few weeks. Local diesel mechanic thought it may be the throttle position sensor if this engine has one.

Miles: 133,000
Recent work: new fuel head and changed fuel filter, new euro torque converter about 5K miles ago. New injectors about 20K miles ago. K&N filter.
Green Diesel Eco Tune

Any ideas on this one? Are throttle bodies, throttle position sensors a problem on this engine?


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 2:57 pm 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Sep 22, 2009 10:16 pm
Posts: 2407
Location: Oxford, Connecticut
You may have a Tare / Rip in your Turbo boost hose.

Inspect it by removing it from the vehicle.

_________________
2005 Jeep Liberty Sport CRD.
2005 Jeep Liberty Limited CRD - Totaled 3/19/2012 (Not at fault), towed to bone yard and sold at auction.
1997 Jeep Sahara, Hunter Green - 307,000m -
1983 MBenz 240D - garaged, midnight blue, showroom condition.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 4:57 pm 
Offline
LOST Member

Joined: Mon Jul 22, 2013 2:40 am
Posts: 165
You are getting air in your fuel.

What happens, is that the high pressure supply pump ingests air, the pressures become unstable, and the computer defaults to "limp" mode.

When you restart it, the bubble has gone through and since the measurements are ok, it is no longer in limp mode.

I had to replace my filter housing, and I had bad hose clamps on the filterhead.

_________________
05 CRD Sport in blue. Suncoast TC and ARP studs.

I have the Sealey timing kit I'll loan out.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 5:58 pm 
Offline
LOST Newbie

Joined: Tue Apr 03, 2012 11:37 pm
Posts: 63
I had the turbo hose come off before and this acted differently. I think the air in the system sounds reasonable since I've had a slight leak on the lift pump feeding the new fuel head. I'll check this out. Meanwhile has anyone else experienced similar symptoms and what fixed the problem?

Thanks for all the help in this forum :-)


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 7:44 pm 
Offline
LOST Newbie

Joined: Wed Oct 30, 2013 5:12 pm
Posts: 8
At 176k the vacuum reservoir solenoid went bad, no turbo, blew tons of smoke. No power, but would idle fine. I bypassed the solenoid to get home (3100 miles) All it does is hold vacuum in the reserve tank when shut off. Hurts nothing to bypass the solenoid just to see if it's the problem.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 10:04 pm 
Offline
LOST Newbie

Joined: Tue Apr 03, 2012 11:37 pm
Posts: 63
Where is this solenoid located? Near the coolant reservoir?

Thanks!


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Thu Nov 14, 2013 11:03 pm 
Offline
LOST Member

Joined: Mon Jul 22, 2013 2:40 am
Posts: 165
jtz54 wrote:
Where is this solenoid located? Near the coolant reservoir?

Thanks!


That solenoid won't limit things until you cycle the key and then run fine again.

_________________
05 CRD Sport in blue. Suncoast TC and ARP studs.

I have the Sealey timing kit I'll loan out.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Fri Nov 15, 2013 8:01 am 
Offline
Lifetime Member
Lifetime Member

Joined: Sun Mar 28, 2010 9:15 am
Posts: 3475
Location: Tallahassee, Florida
solenoid bypass is posted at viewtopic.php?f=5&t=70602&p=757348&hilit=boost+solenoid#p757348

_________________
05 Ltd, GDE Stg II turbo + TCM tune, SunCoast TC w. Transgo kit, Steiger window regulators, Samcos, Fumoto valve, 2nd gen filter head with Lub. Spec. bleeder, Hayden clutch & 11 blade fan, inverted spare, P-1 battery, BF Goodrich Long Trail TAs, Etecno1 glow plugs, timing belt at 50K miles/8 yrs, Miller tools to loan in my immediate vicinity


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Fri Nov 15, 2013 8:31 am 
Offline
LOST Junkie

Joined: Tue Jan 26, 2010 4:26 am
Posts: 530
Location: White River, South Africa
I agree with the comments that it is probably air in the fuel!

But also bear in mind that the 2006 CRD has a known problem whereby the harness going behind the fuel filter bracket can fray to chassis intermittantly! :(


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Fri Nov 15, 2013 9:02 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Sep 22, 2009 10:16 pm
Posts: 2407
Location: Oxford, Connecticut
The engine should be throwing codes...... what are they?

_________________
2005 Jeep Liberty Sport CRD.
2005 Jeep Liberty Limited CRD - Totaled 3/19/2012 (Not at fault), towed to bone yard and sold at auction.
1997 Jeep Sahara, Hunter Green - 307,000m -
1983 MBenz 240D - garaged, midnight blue, showroom condition.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Fri Nov 15, 2013 9:27 am 
Offline
LOST Newbie

Joined: Tue Apr 03, 2012 11:37 pm
Posts: 63
No codes were thrown during the incident which I thought was weird. If the engine goes into limp mode shouldn't it throw a code?

Are the new fuel heads known for leading also? Thought they solved the problems with that.

Going to replace the fitting that's weeping on the lift pump first. Hopefully the "new" fuel head isn't leaking too.

After replacing the bad injector that was causing the intermittent hot start problem the CRD has been relatively trouble free.


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 11:05 am 
Offline
LOST Member

Joined: Sun May 01, 2011 2:27 pm
Posts: 154
Op did you ever figure this out. I'm having the same problem but mine revs to 3k


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 11:30 am 
Offline
LOST Junkie

Joined: Tue May 29, 2012 8:45 am
Posts: 906
Location: Western, PA
Sounds like Air in fuel. Blown boost hose, bad turbo or Rocker's.

_________________
05 Liberty CRD Sport with Leather 115k
GDE ECO, No EGR, no FCV, (system gone)
Oil Drain plug P/N 090-039
K&N Air Filter, 2nd gen Fuel filter head
NEW Rockers & lifters
Mobil 1 0w-40
Stant 13519 195 deg inline Thermostat.
0 281 002 845 MAP
Etecno GX3123 7v Glow Plugs
Advance Gold 800CCA Battery
Traded it for a Quality VW TDI


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 12:46 pm 
Offline
LOST Member

Joined: Sun May 01, 2011 2:27 pm
Posts: 154
kjjet wrote:
Sounds like Air in fuel. Blown boost hose, bad turbo or Rocker's.


To elaborate more... It seems like my tc stall speed has gone up. It takes a little throttle to get going. My jeep isn't blowing any smoke. Does this sound like a bad boost hose. My passenger side is a metal tube that I made and driver side is original I think (130k miles)

I recently change my glow plugs and since, I do hear a faint whistle of air at higher boost coming from the intake elbow hose area. I did not put new gaskets on the intake elbow or fcv when I put it back together


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 1:13 pm 
Offline
LOST Junkie

Joined: Tue May 29, 2012 8:45 am
Posts: 906
Location: Western, PA
Unless there is a hole in a boost hose, loose clamp or a bad leak at the intake elbow? Adding a bit of sealant at the intake elbow should fix and leaks there.
Did you check the turbo inlet pipe and check the turbo shaft for looseness? The turbo shaft should move slightly Fwd to Aft. There should be no movement Left to right.

Good luck
KJJET

_________________
05 Liberty CRD Sport with Leather 115k
GDE ECO, No EGR, no FCV, (system gone)
Oil Drain plug P/N 090-039
K&N Air Filter, 2nd gen Fuel filter head
NEW Rockers & lifters
Mobil 1 0w-40
Stant 13519 195 deg inline Thermostat.
0 281 002 845 MAP
Etecno GX3123 7v Glow Plugs
Advance Gold 800CCA Battery
Traded it for a Quality VW TDI


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 1:32 pm 
Offline
LOST Member

Joined: Sun May 01, 2011 2:27 pm
Posts: 154
Turbo inlet pipe was new about 30k miles ago. I changed it with the tb job. I actually just checked the the turbo on Friday and I couldn't feel any play in it


Top
 Profile  
 
 Post subject: Re: Throttle problem? - No power won't go past 2000 RPM
PostPosted: Mon Dec 30, 2013 1:48 pm 
Offline
LOST Junkie

Joined: Tue May 29, 2012 8:45 am
Posts: 906
Location: Western, PA
Sure sounds like a leak or a lack of turbo boost.

Check your turbo solenoid filter for blockage and if good change the solenoid? There are ways to check to see if its working correctly but off hand I can't tell you. I would make a new post asking for help with turbo boost issues.

Good luck
KJJET

_________________
05 Liberty CRD Sport with Leather 115k
GDE ECO, No EGR, no FCV, (system gone)
Oil Drain plug P/N 090-039
K&N Air Filter, 2nd gen Fuel filter head
NEW Rockers & lifters
Mobil 1 0w-40
Stant 13519 195 deg inline Thermostat.
0 281 002 845 MAP
Etecno GX3123 7v Glow Plugs
Advance Gold 800CCA Battery
Traded it for a Quality VW TDI


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot], halfgig, jeepdan, MSNbot Media and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com