It is currently Sat Dec 15, 2018 3:52 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: 545RFE won't go reverse
PostPosted: Tue Apr 11, 2017 5:57 pm 
Offline
LOST Member

Joined: Wed Nov 19, 2014 4:52 pm
Posts: 133
Just completed full motor re-build,upgraded TC,transgo shift kit,,,everything is wonderful,,except it will not engage reverse, lights come on, everything is normal, just will not engage,,any thoughts?


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Tue Apr 11, 2017 8:22 pm 
Offline
LOST Addict

Joined: Fri Jun 22, 2007 11:43 am
Posts: 4402
Location: Green Cove Springs FL
Will it go into drive?
Whats the fluid level at?

Did you remove the transmission while you did all the engine work?
Is the shift linkage connected properly?
Valve body seated properly when you did the shift kit?

If the trans was working before you did the engine work, then its doubtful that anything went wrong with the planetary gears or clutches.
Most likely cause is low fluid.
Next most likely is valve body.

_________________
Bought my '05 CRD on June 2nd '07, used with 29,000 miles.
intake elbow and EGR delete. 5 volt bosch glow plugs
Yeti stage 2 ECU tune. Straight pipe exhaust. DIY intercooler hoses
Provent and modified factory 180F thermostat
Replaced cylinder head (cracked) at 160,000 miles + ARP studs
2.5 inch lift, JBA upper arms, 235-85-16 tires.
Still love it.


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Tue Apr 11, 2017 10:41 pm 
Offline
LOST Member

Joined: Wed Nov 19, 2014 4:52 pm
Posts: 133
flash7210 wrote:
Will it go into drive?
Whats the fluid level at?

Did you remove the transmission while you did all the engine work?
Is the shift linkage connected properly?
Valve body seated properly when you did the shift kit?

If the trans was working before you did the engine work, then its doubtful that anything went wrong with the planetary gears or clutches.
Most likely cause is low fluid.
Next most likely is valve body.

thanks flash ,the answer is yes to most all your questions, replacing valve body to confirm ,.ill let you know once it comes in


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Wed Apr 12, 2017 11:57 am 
Offline
LOST Addict

Joined: Fri Jun 22, 2007 11:43 am
Posts: 4402
Location: Green Cove Springs FL
I dont know if the actual valve body is bad.
My concern is that if it was reinstalled improperly there could be a miss-alignment between the shift linkage and the manual valve.
Does the shift lever move normally through all positions and can you feel the detents at each position? If not, that would be a clue.

Another possibility is the solenoid pack. Could be a bad low/reverse solenoid.

Still another possibility is the L-R valve in the valve body. Which should have been replaced as part of the transgo kit. Its nothing more than a little aluminum slug. Maybe it somehow got stuck.

And just to be sure you have the proper amount of fluid.
Start the engine, set parking brake, and put it in neutral.
Check fluid. It should be at the full-hot mark.

_________________
Bought my '05 CRD on June 2nd '07, used with 29,000 miles.
intake elbow and EGR delete. 5 volt bosch glow plugs
Yeti stage 2 ECU tune. Straight pipe exhaust. DIY intercooler hoses
Provent and modified factory 180F thermostat
Replaced cylinder head (cracked) at 160,000 miles + ARP studs
2.5 inch lift, JBA upper arms, 235-85-16 tires.
Still love it.


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Tue Mar 13, 2018 11:30 am 
Offline
LOST Member

Joined: Wed Nov 19, 2014 4:52 pm
Posts: 133
flash7210 wrote:
I dont know if the actual valve body is bad.
My concern is that if it was reinstalled improperly there could be a miss-alignment between the shift linkage and the manual valve.
Does the shift lever move normally through all positions and can you feel the detents at each position? If not, that would be a clue.

Another possibility is the solenoid pack. Could be a bad low/reverse solenoid.

Still another possibility is the L-R valve in the valve body. Which should have been replaced as part of the transgo kit. Its nothing more than a little aluminum slug. Maybe it somehow got stuck.

And just to be sure you have the proper amount of fluid.
Start the engine, set parking brake, and put it in neutral.
Check fluid. It should be at the full-hot mark.

yeah there was an issue the new solenoid pack cleared it up,.thank you Brother!


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Fri Mar 16, 2018 12:51 pm 
Offline
Lifetime Member
Lifetime Member

Joined: Mon Jun 18, 2012 5:50 pm
Posts: 1187
Location: Central Indiana
The solenoid pack wasn't bad, you probably just left the old reverse float in there when you installed the new one in the Transgo kit.

Ask me how I know that....

_________________
Silver 2006 KJ 2.8L CRD Limited:
GDE ECO Tune / Fumoto Valve / E-Tecno GX3123 7v Glow Plugs / 2nd Gen Fuel Head / Mishimoto RED Hoses / Rockers/Lifters @ 114k / Hayden FC + 11 Blade Nylon / Sears P1 Battery / Transgo 45RFE-HD2 Reprogramming Kit / Timken Front Bearings


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Thu Aug 30, 2018 10:29 am 
Offline
LOST Member

Joined: Wed Nov 19, 2014 4:52 pm
Posts: 133
Hexus wrote:
The solenoid pack wasn't bad, you probably just left the old reverse float in there when you installed the new one in the Transgo kit.

Ask me how I know that....

lol omg don't tell me! anyhow im selling my crd the tranny bearing in the back broke, the silonoid pack i got for it is still in the tranny and its only got 10k on it im unloading everything crd,(bought a honda) dirt cheap, ive got many many extras for the right enthusiast


Top
 Profile  
 
 Post subject: Re: 545RFE won't go reverse
PostPosted: Thu Aug 30, 2018 10:49 am 
Offline
LOST Addict
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 4234
Location: Central GA
highironcrd wrote:
lol omg don't tell me! anyhow im selling my crd the tranny bearing in the back broke, the silonoid pack i got for it is still in the tranny and its only got 10k on it im unloading everything crd,(bought a honda) dirt cheap, ive got many many extras for the right enthusiast

What do you have?
Maybe post a list? :wink:

_________________
05 Jeep Liberty CRD Limited :JEEPIN:
Blk Brush Guard/Hella's/LED's
Ironman Springs/Bilstein's
Yeti Stg4 MaxTune
Weeks ElbowKit/BatteryTray
NO FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pump
2mic.Sec.Fuel Filter
Flowmaster/NOcat
V6 Airbox
GM11 blade fan/NAPA HDclutch
Ironrock Trilink
98 Dodge Cummins, 5"exh. Viair, Huge K&N


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com