It is currently Tue Jan 23, 2018 12:03 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 5:22 am 
Offline
LOST Newbie

Joined: Mon Feb 13, 2017 6:48 am
Posts: 5
My 05 CRD has an issue where it SOMETIMES runs rough and stalls immediately after start up. It sounds terrible when it does this, runs extremely rough shaking the whole vehicle and often stalls. Sometimes it doesn't quite stall and after 4-6 seconds it will smooth out and idle perfectly. This rough running occurs about 2-3 seconds after I start cranking. When it doesn't do this it starts beautifully. I have worked out that if I continue to crank through this rough running it will run this way for about 4-6 seconds and then come good.

It also occurs straight so soon in the startup that I don't even have a chance to change gears ( its an auto)

Couple of points
This ONLY ever occurs immediately after starting.
It ONLY occurs when the vehicle is cooling down , never when the vehicle is cold and never when I start it within a couple of mins after turning it off.
I have replaced the fuel filter and I'm now checking before I start and I have never found the fuel primer to be soft.
I replaced the Cam and Crank sensors, the relationship of this issue to the engine cooling down pointed me to that as a possible reason.
I have replaced the MAP sensor also after I installed the weeks stage 1 kit
There are no issues when driving, it runs great, I'm getting good fuel economy and it doesn't appear to be lacking power.

the only error code I'm getting ( besides EGR related ones ) is p1140

Its annoying because my mechanic has never seen it do it, I guess he needs to test it more but id like to fix this myself if possible as I cant get him to look at for a few weeks. Id like to avoid taking it to the official dealer also due to their insane prices.

One thing is that the fuel heater has at some time had the heater wire unplugged and a non standard plug fitted which means I can no longer plug the heater in.This makes me think one of the previous owners noted the fuel heater issue that is well documented, however there is no appearance of scorching or fuel leaking and the issue only occurs when starting.

My alternator pulley is exhibiting some red dust, I have a spare and will try replacing it soon, it seems unlikely this is related though?


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 1:40 pm 
Offline
LOST Member

Joined: Sun Dec 12, 2010 5:49 pm
Posts: 152
My first thought: P1140 is the FCV valve. Possibly shut closed and thus limiting air flow to intake (it pulls exhaust into intake when closed). But I see that you installed the Weeks kit, so that blows that theory......


Thought 2: fuel injector problem. Fuel dribbles out after shut down and collects in the dish of the piston. Or maybe it doesn't open at all for a few seconds. Either way causes an imbalance and thus the shaking.

_________________
My collection of CRD's:
2005 Deep Beryl Green Pearlcoat
2006 Light Khaki Metallic Clearcoat
2006 Inferno Red Crystal Pearlcoat
2006 Midnight Blue Pearlcoat
2006 Gold Limited
2015 Black Ecodiesel
2015 Black Ecodiesel 2


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 2:22 pm 
Offline
LOST Addict
User avatar

Joined: Sat Aug 27, 2016 9:12 pm
Posts: 1413
Location: N. Muddle Oregon Coast
Another thought..

The symptoms you describe indicate that all the glow plugs are good, as they work fine when the engine is dead cold, and it starts fine when fully warm, which indicates it's not a fuel problem.

I'm guessing the coolant temperature sensor may be giving faulty information at some point of it's spectrum, and is leading the ECM to believe that the engine is warmer than it really is. The ECM then believing the wrong information, fails to activate the glow plugs when it actually should.

The alternator pulley could have an effect of making it worse, but doubtful that it would be the cause.
Really recommend putting the new unit on before the existing one fails entirely.

edit-spelling errors

_________________
'06 Lbrty Sprt CRD 148Kmi

Sasquatch
DSS Turbo
CAT-elimntr
Weeks Stg1&2 EGRfix
PV-200
BLING
vent gauges

IDParts
head
cams
rockers
Timing set
ARP studs
eTn1 GX2123 5v GPs

Flowmaster 942550
Carter P76611M
GM 12611872
Hayden 2986
GM 15017911
PATC Custom Billet
2010 Ram Hemi Trans
Sonnax 44957
Transgo kit
Cooper 51770

Future plans: GDE Trans tune


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 2:49 pm 
Offline
LOST Addict

Joined: Fri Jun 22, 2007 11:43 am
Posts: 4027
Location: Green Cove Springs FL
Quote:
My 05 CRD has an issue where it SOMETIMES runs rough and stalls immediately after start up

Does it stall immediately when you put the trans into R or D ?
If so, check your trans fluid level at idle while cold. It should be above the full hot mark.

If it stalls before you put it in gear, then it’s a fuel system problem.

If you can, post a picture of your fuel filter head so we can see what you have.

_________________
Bought my '05 CRD on June 2nd '07, used with 29,000 miles.
intake elbow and EGR delete. 7 volt Etecno glow plugs
Yeti stage 2 ECU tune. Straight pipe exhaust. DIY intercooler hoses
Provent and modified factory 180F thermostat
Replaced cylinder head (cracked) at 160,000 miles + ARP studs
2.5 inch lift, 255-75-17 tires.
Still love it.


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 4:10 pm 
Offline
LOST Junkie

Joined: Fri Mar 20, 2015 2:11 pm
Posts: 628
Location: markham, ontario
i say ,, for north american CRD model 1st think to do is get in tank lift pump , and then list gets longer and longer till you get to second page of the modification list , it will take few years to complete .


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Sun Jan 14, 2018 11:58 pm 
Offline
LOST Newbie

Joined: Mon Feb 13, 2017 6:48 am
Posts: 5
GordnadoCRD, it's that the temperature sensor located near / in the thermostat? I don't have a pc but I remember removing one when I replaced the thermostat It occurs to me that could be an explanation as it certainly appears to be related to temperature. I don't beleive it is anyway relayed to the transmission it occurs before I have a chance to change gear.


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Mon Jan 15, 2018 12:32 am 
Offline
LOST Addict
User avatar

Joined: Sat Aug 27, 2016 9:12 pm
Posts: 1413
Location: N. Muddle Oregon Coast
Yes, it threads into the rear of the thermostat housing.

It's the little blue thingy behind the T-stat housing that you can barely see for all the other hoses.

Image

_________________
'06 Lbrty Sprt CRD 148Kmi

Sasquatch
DSS Turbo
CAT-elimntr
Weeks Stg1&2 EGRfix
PV-200
BLING
vent gauges

IDParts
head
cams
rockers
Timing set
ARP studs
eTn1 GX2123 5v GPs

Flowmaster 942550
Carter P76611M
GM 12611872
Hayden 2986
GM 15017911
PATC Custom Billet
2010 Ram Hemi Trans
Sonnax 44957
Transgo kit
Cooper 51770

Future plans: GDE Trans tune


Top
 Profile  
 
 Post subject: Re: 05 CRD stall immediately after starting
PostPosted: Mon Jan 15, 2018 2:12 am 
Offline
LOST Newbie

Joined: Mon Feb 13, 2017 6:48 am
Posts: 5
GordnadoCRD wrote:
Yes, it threads into the rear of the thermostat housing.

It's the little blue thingy behind the T-stat housing that you can barely see for all the other hoses.

Image


I'm thinking given how cheap that part is and easy to replace its worth a shot.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot], papaindigo and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com