It is currently Sat Dec 15, 2018 3:38 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 32 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Mon Sep 17, 2018 10:17 pm 
Offline
LOST Addict
User avatar

Joined: Sat Aug 27, 2016 9:12 pm
Posts: 2100
Location: Oregon Coast Dairy Country. Land of stumps, dumps, and "Liquid Pumps"
A little WD40 could identify if it's timing.

Pull the driver's side intercooler hose loose, and have someone spray into it while it's being cranked. (like ether for a gasoline engine)
DO NO USE A SPRAY TUBE. It could come loose and cause much greater headaches, besides, a stream is not what you want here.
If the engine fires, the timing is fine.
If not, it won't.
However, if the timing is fine, (engine fires) that does not mean that the ECM is bad.

_________________
'06 Lbrty Sprt CRD 150K

Sasquatch
DSS Turbo
CAT-elimntr
Weeks Stg1&2 EGRfix
PV-200
BLING
vent gauges

IDParts
head
cams
rockers
Timing set
ARP studs
eTn1 GX2123 5v GPs

YETI Custom Tune
Flowmaster 8325508
Carter P76611M
GM 12611872
Hayden 2986
GM 15976889
PATC Custom Billet
2010 Ram Hemi Trans
Sonnax 44957
Transgo kit
Cooper 51770


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Tue Sep 25, 2018 10:23 pm 
Offline
LOST Newbie

Joined: Mon Sep 03, 2018 1:42 am
Posts: 21
GordnadoCRD wrote:
A little WD40 could identify if it's timing.

Pull the driver's side intercooler hose loose, and have someone spray into it while it's being cranked. (like ether for a gasoline engine)
DO NO USE A SPRAY TUBE. It could come loose and cause much greater headaches, besides, a stream is not what you want here.
If the engine fires, the timing is fine.
If not, it won't.
However, if the timing is fine, (engine fires) that does not mean that the ECM is bad.
We will try this tomorrow.

Sent from my SM-G965U using Tapatalk


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Tue Sep 25, 2018 10:24 pm 
Offline
LOST Newbie

Joined: Mon Sep 03, 2018 1:42 am
Posts: 21
CRD05LIBERTY wrote:
Your PCM went bad?


Sent from my iPhone using Tapatalk
That was my next guess but didn't know if it was the same for diesel like gas engines.

Sent from my SM-G965U using Tapatalk


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Thu Sep 27, 2018 4:52 am 
Offline
LOST Newbie

Joined: Mon Sep 03, 2018 1:42 am
Posts: 21
GordnadoCRD wrote:
A little WD40 could identify if it's timing.

Pull the driver's side intercooler hose loose, and have someone spray into it while it's being cranked. (like ether for a gasoline engine)
DO NO USE A SPRAY TUBE. It could come loose and cause much greater headaches, besides, a stream is not what you want here.
If the engine fires, the timing is fine.
If not, it won't.
However, if the timing is fine, (engine fires) that does not mean that the ECM is bad.
We tried this and it did sound like the vehicle wanted to start. So, thank you because that rules out timing.

Sent from my SM-G965U using Tapatalk


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Sun Sep 30, 2018 10:13 pm 
Offline
LOST Newbie

Joined: Mon Sep 03, 2018 1:42 am
Posts: 21
CRD05LIBERTY wrote:
Your PCM went bad?


Sent from my iPhone using Tapatalk
So if we replace the PCM, does it need a full reflash of the computer system?

Sent from my SM-G965U using Tapatalk


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Mon Oct 01, 2018 2:21 am 
Offline
LOST Member

Joined: Sat Apr 15, 2017 3:48 am
Posts: 177
Location: White River in the Bush South Africa
It is actually called "ECM" for the diesel CRD.

You need the Dealers, or maybe GDE, to program some items into the new one such as the SKIS anti-theft code, the VIN number, individual fuel injectors have their own parameters set as well.

I have seen some posts where CRD owners have had their bad ECM repaired but I do not know who does this. Rather than buy a new one get one from a Breaker yard and have that re-programmed but make sure you get the correct part number for your year vehicle! :?

My bet is that it is a wiring problem unfortunately though. :wink:


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Mon Oct 01, 2018 3:37 am 
Offline
LOST Addict
User avatar

Joined: Sat Aug 27, 2016 9:12 pm
Posts: 2100
Location: Oregon Coast Dairy Country. Land of stumps, dumps, and "Liquid Pumps"
Sorry I didn't catch this, the first 'go-round'. :oops: :banghead: :oops:

musiclady420 wrote:
Sorry, I wrote the wrong code in previous post. The code is P0340. We had is running for a few days with no weird noises or anything. But only drove it within close proximity to our house even up to 70mph. My husband drove it to his work about 15 minutes away, parked it, went to start it after work and the vehicle wouldn't start. Had it towed home, pulled the code P0340(crankshaft position sensor). Replaced with an OEM replacement from IDparts, wouldn't start. Sent that one back and replaced with an OEM from Chrysler, still won't start. This even has our neighbor who is a Licensed Deisel Mechanic stumped, even works on semis all day.

Sent from my SM-G965U using Tapatalk

From service manual..
P0340-CAMSHAFT POSITION SENSOR CIRCUIT MISSING SIGNAL

This is the one at the back of the engine above the exhaust cam.
https://www.idparts.com/camshaft-position-sensor-liberty-crdecodiesel-p-5260.html

First, though, Check the connector plug for proper ground at pin2, and proper 5v signal voltage at pin3. Don't force a normal sized voltage meter lead into the pin opening, they are way too big. Use a small pushpin or sewing needle held firmly against the meter lead.

And if this gets it running again, please give it another chance. I don't know why but somehow I feel a bit overprotective about these CRDs. :roll:

_________________
'06 Lbrty Sprt CRD 150K

Sasquatch
DSS Turbo
CAT-elimntr
Weeks Stg1&2 EGRfix
PV-200
BLING
vent gauges

IDParts
head
cams
rockers
Timing set
ARP studs
eTn1 GX2123 5v GPs

YETI Custom Tune
Flowmaster 8325508
Carter P76611M
GM 12611872
Hayden 2986
GM 15976889
PATC Custom Billet
2010 Ram Hemi Trans
Sonnax 44957
Transgo kit
Cooper 51770


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Mon Oct 01, 2018 9:18 am 
Offline
LOST Member

Joined: Sat Apr 15, 2017 3:48 am
Posts: 177
Location: White River in the Bush South Africa
This sounds good^^^^

GornadoCRD I think has probably put his finger on the problem....you may be chasing the wrong sensor!

Most owners replace both sensors at the same time with the view that if one goes then the other will soon follow. This may just be a bad connection on the Camshaft sensor as mentioned above. :wink:


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Mon Oct 01, 2018 11:17 am 
Offline
LOST Addict
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 4234
Location: Central GA
Wow! Yes, we totally missed that corrected code post dangit! :banghead: :furious:

This is the location for the Cam position sensor:
Rear of engine on right side.

Image

_________________
05 Jeep Liberty CRD Limited :JEEPIN:
Blk Brush Guard/Hella's/LED's
Ironman Springs/Bilstein's
Yeti Stg4 MaxTune
Weeks ElbowKit/BatteryTray
NO FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pump
2mic.Sec.Fuel Filter
Flowmaster/NOcat
V6 Airbox
GM11 blade fan/NAPA HDclutch
Ironrock Trilink
98 Dodge Cummins, 5"exh. Viair, Huge K&N


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Tue Oct 09, 2018 12:36 pm 
Offline
LOST Newbie

Joined: Fri Jun 01, 2018 4:16 pm
Posts: 20
Why u hijacking this poor ladies thread?

WWDiesel wrote:
Wow! Yes, we totally missed that corrected code post dangit! :banghead: :furious:

This is the location for the Cam position sensor:
Rear of engine on right side.

Image



Sent from my iPhone using Tapatalk


Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Wed Oct 10, 2018 2:19 am 
Offline
LOST Member

Joined: Sat Apr 15, 2017 3:48 am
Posts: 177
Location: White River in the Bush South Africa
Deleted


Last edited by Billybob on Wed Oct 10, 2018 8:55 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Replaced Crankshaft Position Sebsor-No Start!
PostPosted: Wed Oct 10, 2018 6:47 am 
Offline
LOST Newbie

Joined: Fri Jun 01, 2018 4:16 pm
Posts: 20
I was just joking bro lol



Billybob wrote:
CRD05LIBERTY wrote:
Why u hijacking this poor ladies thread?

WWDiesel wrote:
Wow! Yes, we totally missed that corrected code post dangit! :banghead: :furious:

This is the location for the Cam position sensor:
Rear of engine on right side.

Image



Sent from my iPhone using Tapatalk


What! :shock: Mods please delete this post...no hijacking happening here just a lot of members trying to assist!



Sent from my iPhone using Tapatalk


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 32 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com