It is currently Fri Oct 15, 2021 9:48 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 16 posts ] 
Author Message
 Post subject: CRD Not starting after driving
PostPosted: Sat Aug 21, 2021 4:18 pm 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
Recently started having starting issues after driving jeep for a few hours. Would start fine after sitting all day, but would not start unless I cracked the bleeder screw and pumped a few times. Air and fuel would spurt out. Changed fuel filter and drove it all day with no issues multiple starts and stops. Very hot out yesterday and it decided not to start with a trunk full of groceries. I went to do the same procedure, but this time no fuel came out at all after opening the bleeder valve and the pump head was hot. A passerby helped out (a Honda mechanic from a nearby dealer) and got it started by opening the bleed screw while I cranked it over. Will installing an in tank lift pump fix this or only mask the root cause?

227000 km, green diesel eco tune


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Sat Aug 21, 2021 6:02 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 6196
Location: Central GA
Installing an intank lift pump will cure all air in fuel problems forever.
Any leaks on the fuel system will be self evident very quickly after installing the intank pump as fuel will leak out vs air being sucked in. :wink:
Adding an intank lift pump is the second most popular mod to the Jeep CRD behind removing or deleting the EGR system.
It is also reported by many owners who had installed the lift pump that it will also make your engine run slightly smoother.

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 bld.fan/NAPAHDClutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Mon Aug 23, 2021 3:07 pm 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
Thanks, would it be possible to use the wiring from a 3.7 liberty? That wiring harness is pretty expensive. I've found the older threads regarding using the gas liberty wiring, but a lot of the links and photos are dead links.


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Mon Aug 23, 2021 3:51 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 6196
Location: Central GA
jvecchione wrote:
Thanks, would it be possible to use the wiring from a 3.7 liberty? That wiring harness is pretty expensive. I've found the older threads regarding using the gas liberty wiring, but a lot of the links and photos are dead links.

A gasser harrness can be used with a little modifying.
See this:> http://www.auerbach.ca/kj/lift_pump/default.html

You can also just add two additional 16ga wires to your existing harness. That is what I did way back in 2013.
The APEX wire ends are available from Mouser Electronics. > https://www.mouser.com/Connectors/Autom ... bwZ1z1414h

:wink:

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 bld.fan/NAPAHDClutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Mon Aug 23, 2021 6:27 pm 
Offline
LOST Newbie

Joined: Thu Dec 13, 2018 10:05 pm
Posts: 82
Location: SoCal
jvecchione wrote:
Thanks, would it be possible to use the wiring from a 3.7 liberty? That wiring harness is pretty expensive. I've found the older threads regarding using the gas liberty wiring, but a lot of the links and photos are dead links.


That's what I did. got the complete harness out of an 04' 3.7L gasser and transplanted 2 wires into my diesel harness. I think I might have had to extend the wires about 6" but nothing a soldering iron and heat shrink tubing couldn't fix (you have spare wires to use from the gasser harness).
Also, since the sending unit I order, the fuel gauge resistor board contacts were broken, so just swapped my original resistor board to the new sending unit and ran through the fuel range to make sure everything worked before I reinstalled into the tank.
Been running like a champ now even when I took it to MOAB this year and ran a few Badge of Honor trails. :JEEPIN:

_________________
05 CRD Limited; Rebuilt top end w/ARP studs, EGR delete, SEGR, 3.7L HD cooling fan, Samco hoses, gen 2 fuel head, in tank pump, JBA coil overs & control arms, KK clevis fork, 1/2" cradle drop, 1/4" motor mount lift, WJ rear upper adjustable trilink w/WW custom mount, WJ lower control arms, 4:10 gears, front and rear air lockers


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 8:02 am 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
I think I'm going the junkyard route. Ordering the terminals will take at least a week and I can't wait that long. They even have a CRD that I've picked from before for a prop shaft rebuild. Do you know if the pins are the same size for all the Liberty model years?


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 11:36 am 
Offline
LOST Newbie

Joined: Thu Dec 13, 2018 10:05 pm
Posts: 82
Location: SoCal
Yes they should be. Only difference was I believe in 07' they went to individual wheel speed sensors at the wheels for the ABS vs the speed sensor on top of the rear diff. But regardless the pins/connector is the same under the rear seat and at the tank end.

PS. if that CRD in the junkyard is an 05' you should at the very least grab the FCM under the battery tray. Those things are no longer available and that box can cause a lot of problems if it goes out. Good to have a spare just in case!

_________________
05 CRD Limited; Rebuilt top end w/ARP studs, EGR delete, SEGR, 3.7L HD cooling fan, Samco hoses, gen 2 fuel head, in tank pump, JBA coil overs & control arms, KK clevis fork, 1/2" cradle drop, 1/4" motor mount lift, WJ rear upper adjustable trilink w/WW custom mount, WJ lower control arms, 4:10 gears, front and rear air lockers


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 11:57 am 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 6196
Location: Central GA
03black wrote:
Yes they should be. Only difference was I believe in 07' they went to individual wheel speed sensors at the wheels for the ABS vs the speed sensor on top of the rear diff. But regardless the pins/connector is the same under the rear seat and at the tank end.

PS. if that CRD in the junkyard is an 05' you should at the very least grab the FCM under the battery tray. Those things are no longer available and that box can cause a lot of problems if it goes out. Good to have a spare just in case!

Very Good Advice!!! :D I picked up a spare one last year and tucked it away "Just in case"!

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 bld.fan/NAPAHDClutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 12:46 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 6196
Location: Central GA
jvecchione wrote:
I think I'm going the junkyard route. Ordering the terminals will take at least a week and I can't wait that long. They even have a CRD that I've picked from before for a prop shaft rebuild. Do you know if the pins are the same size for all the Liberty model years?

The APEX terminals for 05 & 06 are the same on both ends at the connector on top of the fuel tank and the connector under the rear seat.
Not sure about other year models, but the Mopar Connection Repair Web site shows the connector 05013978AA -- MODULE-FUEL PUMP - (FUEL_TANK) 4 WAY is the same from 1997 - 2022 on all Chrysler/Jeep models on the fuel tank module. This includes KJ, JK, WK, and many others. :D
You can go to this web site and plug in the part no. 05013978AA, in the "KIT NUMBER" search block and it will show you all the different models it was used on. :wink:
MOPAR CONNECTION REPAIR KITS

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 bld.fan/NAPAHDClutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 1:41 pm 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
03black wrote:
Yes they should be. Only difference was I believe in 07' they went to individual wheel speed sensors at the wheels for the ABS vs the speed sensor on top of the rear diff. But regardless the pins/connector is the same under the rear seat and at the tank end.

PS. if that CRD in the junkyard is an 05' you should at the very least grab the FCM under the battery tray. Those things are no longer available and that box can cause a lot of problems if it goes out. Good to have a spare just in case!


I have a 2006. Do you want me to ask if its available for you?


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 3:07 pm 
Offline
LOST Newbie

Joined: Thu Dec 13, 2018 10:05 pm
Posts: 82
Location: SoCal
jvecchione wrote:
I have a 2006. Do you want me to ask if its available for you?


It would be nice but not necessary. I took mine out, sealed up the edges/seams and the unused plug connector with nonconductive foam and RTV. But grab it in case someone else calls out for it. The CRD community is small and every chance we get to help each other out is another CRD Liberty that gets to stay on the road.

_________________
05 CRD Limited; Rebuilt top end w/ARP studs, EGR delete, SEGR, 3.7L HD cooling fan, Samco hoses, gen 2 fuel head, in tank pump, JBA coil overs & control arms, KK clevis fork, 1/2" cradle drop, 1/4" motor mount lift, WJ rear upper adjustable trilink w/WW custom mount, WJ lower control arms, 4:10 gears, front and rear air lockers


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 5:26 pm 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
The harness from the wrecked CRD was cut already. Will I have enough male and female terminal pins to add to my existing harness to connect the lift pump? Image

Sent from my LG-H831 using Tapatalk


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Tue Aug 24, 2021 8:53 pm 
Offline
LOST Newbie

Joined: Thu Dec 13, 2018 10:05 pm
Posts: 82
Location: SoCal
From the looks of it...yes. you will have to de-pin 2 female contacts and 2 male contacts from those connectors (your going to make 2 wire segments).
Then measure a length of wire that is the length of your existing harness and splice 1 female to 1 male contact and then pin it into your existing harness....rinse and repeat for 2nd wire.

Soldering and heat shrink tubing will be the best connection, then wrap the splice with electrical tape, then install into the split wire loom.
To get the contacts out, slide, pry, lift the "green lock" out from the face of the connector (it will not come off/out) and using a small flat head jewelers screw driver or something thin and flat (I made mine from a small cotter pin ground down) push into the face of the pin (not where contact slides into but rather the edge) and the pull the wire out from the back of the connector. Takes a bit of finesse but you'll get it. Be careful not to bend or break the metal tab on the connector as that is what locks it into the plastic receptacle.

Should be about an 1hr of work depending on your wiring skill level.

_________________
05 CRD Limited; Rebuilt top end w/ARP studs, EGR delete, SEGR, 3.7L HD cooling fan, Samco hoses, gen 2 fuel head, in tank pump, JBA coil overs & control arms, KK clevis fork, 1/2" cradle drop, 1/4" motor mount lift, WJ rear upper adjustable trilink w/WW custom mount, WJ lower control arms, 4:10 gears, front and rear air lockers


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Thu Sep 09, 2021 12:37 pm 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
Well I'm still waiting for the lift pump from sasquatch parts so I have been avoiding driving the jeep. I had to drive my kids to school and it started after sitting for a couple weeks. When I accelerated the abs, esp and traction control lights flashed on and off and it went into limp mode. I barely made it home. I did have the fuel filter head heater unplugged and capped to see if i had a leak and forgot to plug it back in. Could this be a related issue?

Sent from my LG-H831 using Tapatalk


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Fri Sep 17, 2021 11:11 am 
Offline
LOST Newbie

Joined: Sat Jan 06, 2018 2:23 pm
Posts: 27
darn, this was a lot of work. I'm wishing I would have cut an access panel. Anyway, I had to cut these fuel lines, i just could not get them to release. Can I just use rubber fuel line?Image

Sent from my LG-H831 using Tapatalk


Top
 Profile  
 
 Post subject: Re: CRD Not starting after driving
PostPosted: Sun Sep 19, 2021 5:31 pm 
Offline
LOST Member
User avatar

Joined: Mon Jul 11, 2011 8:06 pm
Posts: 271
Location: Lebanon, KY, USA
Should be no problem. I replaced my hoses with rubber since my fittings leaked air. Runs so much better without air in the fuel, and was way easier than either an airdog/fass type of fix or the in-tank pump.

_________________
2005 Liberty Limited CRD; Air Filter Monitor; Samco Hoses; GDE HOT Tune; RL037142AA TC; KJ Interior Rack from All J Products; JBA Adjust-a-strut lift and A-Arms; 245/75R16 Firestone Destination ATs on Moabs; ARB Bumper; ASFIR Skids; FS-2500 Bypass Filter; ARP studs.
2016 Grand Cherokee Overland CRD.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Majestic-12 [Bot], PZKW108 and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com