It is currently Wed Jul 18, 2018 5:07 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Gas Mileage vs temperature
PostPosted: Thu Jul 09, 2009 9:30 pm 
Offline
LOST Newbie

Joined: Mon Apr 06, 2009 8:32 pm
Posts: 29
Location: Del Rio, TX
I have a Liberty with the 4 Cy engine. It was absolutely great on gas mileage until I started tinkering with a lift, tires etc....which is to be expected. Still, with 265/70R17 tires I get over 20 MPG on reasonably level terrain.

Where my mileage falls off is on hotter days. I can see an obvious difference in engine performance & gas mileage between a 65 F day and one that's 85 F.

When it gets into the 90's the Liberty starts to run poorly. I have to drop a gear to get up hills and the gas mileage suffers when it hits 95 F. I keep it tuned up and doesn't miss, but it's had this issue since about 30K miles.

Any ideas?

_________________
Blue KJ I-4, 5spd, Al's cut CV's. Powertrax Rear/ Det Tru-Trac Front, OME 927HD, Gen5 arms, Rancho 17005, Rusty's Top Plate. Rear: OME HD springs, OME 132 long travel, 17" Raceline Wheels 3/4" offset


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 09, 2009 9:33 pm 
Offline
Lifetime Member
Lifetime Member

Joined: Sat Apr 01, 2006 9:38 pm
Posts: 13114
Location: Colorado Springs
Have you changed the plugs and wires? Diff fluids? Manual trans fluid? You will get worse mpg's in hot weather from running AC and also the intake air temps are increased,hot air is less dense then colder air.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 09, 2009 10:22 pm 
Offline
LOST Newbie

Joined: Mon Apr 06, 2009 8:32 pm
Posts: 29
Location: Del Rio, TX
tjkj2002 wrote:
Have you changed the plugs and wires? Diff fluids? Manual trans fluid? You will get worse mpg's in hot weather from running AC and also the intake air temps are increased,hot air is less dense then colder air.


Sure have, well most of that. Just finished changing out 5 speed fluid and will get diff cases again soon. As for tune up, I have all new plugs, wires, air cleaner etc etc.... As I mentioned before, then decided to come over here and get serious about finding an answer.... There are two temperature sensors on a Liberty, one is for outside temp vs air cond and the other I believe is air intake temperature. That second one might be my problem. Then there is the oxygen sensor, not sure if the Liberty turns on the red engine light when that goes bad or not. I should change it just to be sure.

Correct on the less dense air, but I got through all the mountain passes last summer going to Salt Lake City. I took the back roads not the Interstates and the little engine made it, with good use of the 5 speed of course.

_________________
Blue KJ I-4, 5spd, Al's cut CV's. Powertrax Rear/ Det Tru-Trac Front, OME 927HD, Gen5 arms, Rancho 17005, Rusty's Top Plate. Rear: OME HD springs, OME 132 long travel, 17" Raceline Wheels 3/4" offset


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com