It is currently Mon Sep 25, 2017 2:45 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: 2006 Liberty CRD intermittent starting issue
PostPosted: Fri Mar 31, 2017 1:38 pm 
Offline
LOST Newbie

Joined: Fri Mar 31, 2017 1:26 pm
Posts: 1
I have been having some intermittent starting problems with my beloved jeep. When it is really cold, like -10 it does not want to start unless I plug it in. Sometimes, even if its warmer, I have to run the glow plug cycle, turn off key, then try again and start. I was reading somewhere that it could be the crank position sensor? Is there anyone that can confirm this? I don't have the money to be taking to dealership and trying this and that before it works. I need it working properly like yesterday. I am a single parent and need a properly working vehicle asap!!

Thanks in advance :banghead:


Top
 Profile  
 
 Post subject: Re: 2006 Liberty CRD intermittent starting issue
PostPosted: Mon May 01, 2017 1:57 am 
Offline
LOST Newbie

Joined: Sat Apr 15, 2017 3:48 am
Posts: 39
Location: Johannesburg South Africa
jeeplvr06 wrote:
I have been having some intermittent starting problems with my beloved jeep. When it is really cold, like -10 it does not want to start unless I plug it in. Sometimes, even if its warmer, I have to run the glow plug cycle, turn off key, then try again and start. I was reading somewhere that it could be the crank position sensor? Is there anyone that can confirm this? I don't have the money to be taking to dealership and trying this and that before it works. I need it working properly like yesterday. I am a single parent and need a properly working vehicle asap!!

Thanks in advance :banghead:


You definitely need to have any stored codes read out for you by the Dealers or by one of the shops that provide this service for you so that you may have some idea where the fault lies.

I am no expert on starting problems in cold climates....last time I saw snow here in SA was in 1981....but maybe your glow plugs are in need of replacing if they have not been done so recently.

There are lots of posts on this forum regarding glow plug replacements...changing from the original 7 volt ceramics to 5 volt metal plugs...includes new glow plug module and re-programming the ECM or maybe staying with the old programming. Some owners have moved to plugs from Italy...called Etechno I think. My old Export 2002 CRD still has the original 11 volt plugs but they hardly get called into use here in SA!

You can use the "search" function on this forum for glow plugs....try search on "5v glow plugs"...lots of discussion there.
Could also be issues with the type of fuel you are using, Biodiesel for example.. ask the Experts.

The best section to post CRD problems is the section below...."Liberty CRD Love That Torque"....this is where the CRD Experts hang out and there is a very good NOOB GUIDE which is well worth reading. :wink:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com