It is currently Mon Feb 24, 2020 8:37 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: 2006 Jeep Liberty CRD Diesel
PostPosted: Wed Jul 01, 2015 6:30 pm 
Offline
LOST Newbie

Joined: Sat Oct 04, 2014 4:57 pm
Posts: 2
Afternoon everyone. Its Canada Day but I am having difficulty celebrating this holiday. My 2006 CRD diesel Liberty (just under 100,00 miles) is completely lacking any power and easily smokes black continuously and detonates or pings at the touch of the accelerator. If driving on level ground, little smoke. Timing belt is taut and in good condition from what I can see of it. Timing belt slippage seems highly unlikely even though it is approaching it's replacement time.
This is what I have chronologically done to figure out my problem!

Removed mostly plugged catalytic converter for now.
Had it scoped at local dealership. No fault codes. Turbo boost actuator tested and injectors tested OK, but NOT pulled. Cylinder compression OK
Removed EGR, was not very dirty. Tested out OK. Re-installed. Replaced my MAP sensor. It had been coming on intermittently. Had cleaned it recently.
Pulled injectors and replaced all. Dealership did not pull them, claimed they were ok. Sometimes I think they are afraid to get dirty!!
The injectors were not OK. Could not rebuild. Got a core fee but still expensive.
My partner is ready to shoot something.
It has to be a timing issue does it not. But the belt looks good. Timing signals have to be off somewhere?? Everything else is good to go!! Cam Sensor??? Any codes or engine lite
for the cam sensor? What about the Crank Sensor.?
I dont know where to look at this point?!!
Vern, Nanoose Bay, Van. Island, Can.


Top
 Profile  
 
 Post subject: Re: 2006 Jeep Liberty CRD Diesel
PostPosted: Sat Jul 04, 2015 10:28 pm 
Offline
LOST Junkie

Joined: Mon Mar 24, 2008 10:26 pm
Posts: 862
Location: West Coast, Canada
Let's start with something simple. Have you inspected your boost hoses? Are they original or have they been replaced?

_________________
2006 Liberty CRD Limited

Provent @ 43,000 km
SEGR in progress
SAMCO Sport hoses @ 48500 km
Goodyear Wrangler Duratrac LT225/75R16


Top
 Profile  
 
 Post subject: Re: 2006 Jeep Liberty CRD Diesel
PostPosted: Sun Jul 05, 2015 4:07 am 
Offline
LOST Junkie

Joined: Tue Jan 26, 2010 4:26 am
Posts: 844
Location: Hoedspruit , South Africa
Totaly agree with Wolverine here...check the boost hoses for tears,rips etc.
Also the hose from Airbox to Turbo tends to tear.

Cam sensor and crank sensor problems tend to grind you to a complete halt.

The 2006 LHD CRD has a known problem of the Fuel filter head mounting bracket can pinch the harness behind it and cause shorts to chassis but start with the hoses first. :wink:

Best thing is to place your questions in the "Liberty CRD Love the Torque" section further down where there are a lot of experts on the CRD to solve your problems.....read the NOOB section first! :)

_________________
2002 Export CRD 2.5 Sport


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com