It is currently Fri Nov 24, 2017 11:38 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: 1995 ZJ stalling problem
PostPosted: Sat Apr 27, 2013 11:34 am 
Offline
LOST Newbie

Joined: Thu Mar 04, 2010 12:25 am
Posts: 10
Lately my 95 ZJ will just cut off almost as if I turned off the ignition, while driving. If I try to restart it immediately, it will turn over but not start. If I wait 30 seconds, it starts on the first turn of the key. I can hear the fuel pump activate when I attempt to start it so i don't think it's that. I am going to replace the fuel filter, but the way it acts doesn't seem like a clogged filter.
Anyone ever experience this and if so how do i fix it?
Thanks.


Top
 Profile  
 
 Post subject: Re: 1995 ZJ stalling problem
PostPosted: Wed May 29, 2013 11:24 pm 
Offline
LOST Newbie

Joined: Fri May 17, 2013 9:08 am
Posts: 16
Location: Ohio
That's where I would start, always good to start cheap, no cel's?

_________________
2005 liberty CRD just bought-black
95 grand cheroke limited-retired to the woods
97 ram cummins


Top
 Profile  
 
 Post subject: Re: 1995 ZJ stalling problem
PostPosted: Thu Mar 13, 2014 12:55 am 
Offline
LOST Junkie
User avatar

Joined: Wed Jan 11, 2012 9:04 pm
Posts: 644
Location: Houston, TX
Does it feel sluggish when doing so? Like the pedal goes spongy? Could be a bubble in the fuel line or vapor lock. My zj was cursed with it I loved the 4.0 but could never figure out how to fix that problem

Sent from my HTC One using Tapatalk

_________________
2008 Black Liberty Sport 4X4 - Red and Black wheels and trim - Painted headlight bezels - Magnaflow Exhaust.


Top
 Profile  
 
 Post subject: Re: 1995 ZJ stalling problem
PostPosted: Thu Mar 13, 2014 7:02 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Wed Jul 18, 2012 8:53 pm
Posts: 1732
Location: Way South Central PA
I have a friend who just had this problem, check the wiring running to your coil(s). His had a spot that was grounding and would shut off (same exact symptoms you are describing). Once he found it he wrapped it with electrical tape and protected it with wire loom. No problems since.

_________________
2003/3.7 SOLD

2007 Wrangler


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com