It is currently Tue Dec 01, 2020 4:37 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 19 posts ] 
Author Message
 Post subject: C107C & C1404 '08 KK
PostPosted: Sun May 03, 2020 6:18 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
So first I have to say there's great information and topics on here. This is my first time posting, and hope to get some help.
I've had an '08 KK Sport 4x4 (104k miles) for a while, but hasn't really been driven as I had a company vehicle.
I was recently laid off, and am trying to get it back on the road.
I've fixed quite a few issues, but am running into a dead end regarding C107C and C1404 codes. I pulled them from a Bluetooth obd2 reader using OBD Jscan and also a traditional code reader.
So far, I've replaced all 4 wheel speed sensors and brake pedal switch. During the course of getting it ready I also replaced all 4 tires, and brake pads all around.
Once I've read the codes, I clear them and they both come back up active immediately.
Mainly I'm after fixing the ABS/ESP since it affects safety, and the 4x4 can wait a while if need be.
Much appreciation ahead of time for reading this post and sharing any insight you may have.

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Wed May 06, 2020 4:16 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Mar 31, 2009 4:03 am
Posts: 1501
Location: S.W Washington
C107C brake pedal switch 1/2 stuck.
This can be a problem with the brake pedal switch.
This can happen when you install a new switch and the internal cam pops out before it is in place.
The brake pedal switch is a 1 time use. Meaning if removed it has to be replaced.
When replacing it do not allow the plunger to pop out before it is in place. Once in place release it against the brake pedal stop/push pad.
But, it can also be an issue with the ABS, wires, and more.

C1404-Transfer case range position sensor circuit low.
Sensor input voltage is below a specified value.
Check for 5V at the transfer case motor Pin 1.

_________________
07 KA Light Khaki, Manual trany.
2.5" Adjust-A-Strut JBA lift, Euro taillights,
Home made; Front Tilt Hood, Roof Rack, RAM Air, & CAI.
ESP Off Switch
Take a ride on the Trō side!

Image


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Thu May 07, 2020 10:46 am 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Thanks for the reply. I installed the new brake pedal switch per instructions and as you stated. Still have the issues. I'm honestly thinking it could be wiring related as I shook around some wires on the passenger side under the hood to see if anything seemed off. Once when I started the vehicle it displayed esp off, then wouldn't do it again.
Any tips on where or how to start tracking down wiring issues?
Also, thanks for the input on the case sensor, I read the sensor voltage using the Jscan app and it was 4.9-5. I'll check is physically with a meter soon.


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Fri May 08, 2020 5:11 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Mar 31, 2009 4:03 am
Posts: 1501
Location: S.W Washington
Are fuses M1 and M37 OK?
Check for B+ 12V on pin 1 of the brake switch harness.
Are your brake lights "on" when the pedal is not pressed? Are they "on" when depressed?

Ignition off.
Measure the Ohm between the ground circuit terminal (pin 6) and the Brake Signal 1 circuit terminal (pin 5) in the brake switch.
Apply and release the brake switch while monitoring the ohmmeter.
The resistance should change from below 5.0 ohms to an open circuit.

Measure the Ohm between ground terminal (pin 6) and the brake signal 2 circuit (pin 4) in the brake switch harness connector. The resistance should be above 100 ohms.

_________________
07 KA Light Khaki, Manual trany.
2.5" Adjust-A-Strut JBA lift, Euro taillights,
Home made; Front Tilt Hood, Roof Rack, RAM Air, & CAI.
ESP Off Switch
Take a ride on the Trō side!

Image


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Mon Jun 29, 2020 3:57 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Sorry for the delay in responding, moving and life takes precedence.

As for the fuses, both are fine and in working condition.
The brake lights turn on and off as they're supposed to when operating the pedal.
When measuring the ohms, I see the resistance change as you noted.
When checking ohms between pins 6 and 4, it was indeed above 100.

One thing I noticed when doing these steps, when I unplugged the harness from the brake pedal switch, the ABS and ESP BAS lights turned off and the esp off message flashed on the dash. Could this be an indication that the new switch I installed could be bad or installed incorrectly?

Sent from my SM-T720 using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Sun Jul 05, 2020 10:46 am 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Another update, I ended purchasing another brake like switch and it didn't correct the issue. I'm wondering if it could be the ABS module under the hood beside the TIPM.

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Mon Jul 06, 2020 3:20 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Mar 31, 2009 4:03 am
Posts: 1501
Location: S.W Washington
Will151 wrote:
Sorry for the delay in responding, moving and life takes precedence.

As for the fuses, both are fine and in working condition.
The brake lights turn on and off as they're supposed to when operating the pedal.
When measuring the ohms, I see the resistance change as you noted.
When checking ohms between pins 6 and 4, it was indeed above 100.

One thing I noticed when doing these steps, when I unplugged the harness from the brake pedal switch, the ABS and ESP BAS lights turned off and the esp off message flashed on the dash. Could this be an indication that the new switch I installed could be bad or installed incorrectly?

Hope you had the battery Neg cable off while working on your rig.
If not do so now for 10 minutes.
Will151 wrote:
Another update, I ended purchasing another brake like switch and it didn't correct the issue. I'm wondering if it could be the ABS module under the hood beside the TIPM.

Sent from my Pixel 3 XL using Tapatalk

Are you still getting the same codes?

_________________
07 KA Light Khaki, Manual trany.
2.5" Adjust-A-Strut JBA lift, Euro taillights,
Home made; Front Tilt Hood, Roof Rack, RAM Air, & CAI.
ESP Off Switch
Take a ride on the Trō side!

Image


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Mon Jul 06, 2020 11:11 am 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
While doing all of this, no I did not. Before installing another switch I did an overnight reset which included disconnecting the battery and unplugging the TIPM overnight. I'll disconnect the negative as you suggest to today and report back.

Yes, still getting the same codes even after clearing them.

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Wed Oct 07, 2020 12:31 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Hate to bump this thread after not replying, but I'm still not able to correct this.
I ended up purchasing a genuine mopar brake pedal switch from the Jeep dealer today. After installing it, it's still not correcting the brake pedal switch 1/2 stuck issue.
One thing I noticed yesterday when messing with it, if I unplug the switch from the harness, the code goes away and the abs operates correctly. Plug back in, and code comes back and no abs.
I measured the resistance as previously suggested and it's above 100 ohms, jumps around 125-135.

If anyone has anymore suggestions please let me know. I appreciate your time.

Thanks,
William


Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Thu Oct 08, 2020 7:05 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Ok I found the wiring harness diagram, and comparing it to mine. Does anyone else think the wiring on the brake pedal switch harness doesn't match the diagram? Almost like someone previously re-pinned the connector and did it incorrectly? Or am I just interpreting it incorrectly?ImageImage

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Fri Oct 09, 2020 3:38 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 5807
Location: Central GA
What is your year model?
And can you post a link to wiring diagram? The picture you posted is too fuzzy to read. :(

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox
GM11 bld. fan/NAPA HDclutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Sat Oct 10, 2020 11:24 am 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
https://cardiagn.com/2008-jeep-kk-syste ... -diagrams/
I had to screenshot it since you can't save, so that's why it's blurry.
2008 Liberty Sport 4x4

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Sat Oct 10, 2020 2:15 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 5807
Location: Central GA
I was able to download the PDF. I broke out the brake light switch WD and your connector picture you posted.
Can you see the numbers listed on the black connector? Are they 1,2,3,4,5,6 in order? Need a pinout diagram!
If the numbers are in order 1-6, then the wiring is correct based on the numbers listed on the wiring diagram.
But if the pinout numbers are not in order on the connector, which I doubt very seriously, then there is a possibility of being incorrect, but without a pinout diagram it is hard to say for sure.
I looked at the pinout for our 05 & 06 Libertys and the numbers are in order 1-6.

Image

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox
GM11 bld. fan/NAPA HDclutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Tue Oct 13, 2020 1:32 am 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Mar 31, 2009 4:03 am
Posts: 1501
Location: S.W Washington
08 manual;
1 LG/RD FUSED B(+)
2 WT/DG BRAKE LAMP SWITCH OUTPUT
2 WT/TN BRAKE LAMP SWITCH OUTPUT
3 PK/LG FUSED IGNITION SWITCH OUTPUT (RUN-START)
4 LB/DG BRAKE SIGNAL 2
5 BK/DB GROUND
6 DG/WT BRAKE SIGNAL 1

Looking at the troubleshooting it seems to lead to an ABS module problem.

_________________
07 KA Light Khaki, Manual trany.
2.5" Adjust-A-Strut JBA lift, Euro taillights,
Home made; Front Tilt Hood, Roof Rack, RAM Air, & CAI.
ESP Off Switch
Take a ride on the Trō side!

Image


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Wed Oct 14, 2020 10:21 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
I'm leaning that direction myself, but am having difficulty being sure.
With unplugging the brake switch and the abs module functioning properly, could it still be the abs module?
I'd like to try it, but being around ~$400 and require programming I'd rather not.

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Wed Oct 21, 2020 10:26 am 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
So I've found a you pull it part yard ~45 mins away with a 2009 jeep liberty, haven't gone to check it yet.
Does anyone know of the 2009 and 2008 abs module are interchangeable? I've searched multiple sites and can't confirm or deny it'll work if I go pull it.

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Wed Oct 21, 2020 1:55 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
Also, I've attached screenshots of sensor states. Does anyone see something that could be telling or that's off?ImageImage

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Mon Oct 26, 2020 2:24 pm 
Offline
Lifetime Member
Lifetime Member
User avatar

Joined: Tue Mar 31, 2009 4:03 am
Posts: 1501
Location: S.W Washington
An ABS module has to be programmed and initialized to your rig. Not sure if you can reprogram one...

In the screen shots the brake pedal status is "brake on"
Switch 1 is showing "on"
Switch 2 is showing "off"
Brake switch status shows "Pressed"
Brake switch status(hardwired) reads "released"

Brake pressure sensor reads "Pressed"

When you took the screenshots, was your foot on the brake pedal?

_________________
07 KA Light Khaki, Manual trany.
2.5" Adjust-A-Strut JBA lift, Euro taillights,
Home made; Front Tilt Hood, Roof Rack, RAM Air, & CAI.
ESP Off Switch
Take a ride on the Trō side!

Image


Top
 Profile  
 
 Post subject: Re: C107C & C1404 '08 KK
PostPosted: Thu Oct 29, 2020 8:06 pm 
Offline
LOST Newbie

Joined: Sat Jan 26, 2019 8:13 pm
Posts: 12
Location: East Texas
When I took the screenshot of pedal up, no. My foot was hovering above it.
Still thinking ABS module or any other direction I should chase?

Sent from my Pixel 3 XL using Tapatalk


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com