It is currently Fri Oct 22, 2021 11:43 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: '11 KK Crank position codes
PostPosted: Sun Jun 27, 2021 8:34 pm 
Offline
LOST Newbie

Joined: Fri Apr 08, 2011 12:59 pm
Posts: 12
Driving home earlier engine light kicked on immediately followed by traction control light. Few minutes later as I pulled into my driveway engine light started blinking. Ran key cycle for codes and got p0315 and p0335. Both associated with crank sensor. Ran and got a new one from autozone put it in jeep started right up and idled smooth for 2-3 mins. I disconnected the battery to clear codes and when reconnected now the jeep cranks for a good 5-6 seconds before it fires and seems to be misfiring pretty bad. Any ideas what's going on? Seems odd it Ran fine until the battery was disconnected and reconnected. Also from what I've read around the forums the autozone (duralast) crank sensor may be to blame and I need to go to the dealer tomorrow for an OEM sensor? Any ideas greatly appreciated


Top
 Profile  
 
 Post subject: Re: '11 KK Crank position codes
PostPosted: Sun Jun 27, 2021 9:43 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sat Aug 24, 2013 11:36 pm
Posts: 6209
Location: Central GA
Did you get the Duralast Brand? It normally is a reboxed Bosch brand sensor which is the OEM sensor.
Or did they sale you some other brand?
Duralast Crankshaft Position Sensor Part #SU8492

Simply disconnecting the negitive battery cable should not have affected a new crank sensor. :shock:
A crank sensor normally either works or it don't, there is no inbetween.

_________________
Supporting Vendor and Moderator of LOST
05 Jeep Liberty CRD Limited :JEEPIN:
Ironman Springs/Bilstein/Shocks
Yeti StgIV Hot Tune
Sasquatch BatteryTray
No FCV/EGR
Samcos/ProVent
SunCoast/Transgo
Carter Intank-pmp
2mic.Sec.Fuel Filter
Flowmaster/NO CAT
V6Airbox/noVH
GM11 bld.fan/NAPAHDClutch
IronrockArms/wwdieselMount


Top
 Profile  
 
 Post subject: Re: '11 KK Crank position codes
PostPosted: Mon Jun 28, 2021 5:30 am 
Offline
LOST Newbie

Joined: Fri Apr 08, 2011 12:59 pm
Posts: 12
Yeah it was supposed to be a duralast, the dude there said there were 2 options for it, SU13886 and SU8587. The 13886 didn't even look close so I went with the 8587.

And yeah thats where I'm confused, it started and idled perfect after the new sensor but before battery disconnect. Only thing was the engine light stayed on


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group. Color scheme by ColorizeIt!
Logo by pixeldecals.com